Let's Encrypt SSL Certificate Issuance Errors
Incident Report for Hawk Host Inc.
Resolved
This issue has been resolved and certificates can be successfully issued once again. Our systems will run AutoSSL and update your certificates automatically as usual, alternatively you can manually issue any previous failed certificates using the SSL/TLS Status interface in cPanel.
Posted Sep 24, 2019 - 11:28 EDT
Investigating
Our team is aware of an issue preventing issuance of new SSL certificates via Let's Encrypt. This issue appears to be upstream and we are working on gathering more information now.
Posted Sep 24, 2019 - 10:25 EDT