Support Area Maintenance
Incident Report for Hawk Host Inc.
Resolved
The maintenance on https://support.hawkhost.com/ has been completed.
Posted 6 months ago. Apr 05, 2019 - 11:31 EDT
Identified
We are currently performing maintenance on https://support.hawkhost.com/ during this time you'll be unable to open tickets via this portal. We estimate this maintenance will take up to 30 minutes.
Posted 6 months ago. Apr 05, 2019 - 11:05 EDT
This incident affected: Main Website.