Helpdesk Ticket System Availability
Incident Report for Hawk Host Inc.
Resolved
The issue with our helpdesk support system through our client area at https://my.hawkhost.com has now been resolved.
Posted Sep 24, 2021 - 22:31 EDT
Investigating
We are currently investigating an issue impacting our helpdesk support system through our client area at https://my.hawkhost.com. Until this issue is resolved customers can email support@hawkhost.com for any help requests. This issue has no impact on the status of client websites / hosting services.
Posted Sep 24, 2021 - 09:20 EDT
This incident affected: Main Website.