Washington DC Performance Degradation
Incident Report for Hawk Host Inc.
Resolved
The root cause of this issue has been identified and resolved. All services should be operating normally at this time. Please contact our support helpdesk if you continue to experience any problems.
Posted about 1 year ago. Nov 28, 2017 - 17:59 EST
Investigating
We are currently investigating performance issues with multiple systems in our Washington DC datacenter.
Posted about 1 year ago. Nov 28, 2017 - 17:28 EST