Support via Email Temporarily Unavailable
Incident Report for Hawk Host Inc.
Resolved
This issue has been resolved.
Posted 10 months ago. Apr 23, 2018 - 11:51 EDT
Identified
Clients looking to receive email based support can open new tickets by emailing the address help@hawkhost.com.
Posted 10 months ago. Apr 22, 2018 - 11:44 EDT
Investigating
We are looking into an issue impacting support tickets that are submitted and replied to via email. Any customers who need assistance should open a ticket through https://my.hawkhost.com/supporttickets.php directly. Please note you will need to reply through the client area as well as this email issue is impacting both new tickets and ticket replies.
Posted 10 months ago. Apr 22, 2018 - 10:40 EDT