Outgoing Email Issues
Incident Report for Hawk Host Inc.
Resolved
This email issue has been resolved and all clients should see normal delivery times.
Posted 2 months ago. Apr 16, 2019 - 14:05 EDT
Identified
Our team is aware of outgoing email issues on various servers resulting in delayed delivery. This is being actively investigated and updates will be posted as they're available.
Posted 2 months ago. Apr 15, 2019 - 22:40 EDT