Helpdesk Currently Unavailable
Incident Report for Hawk Host Inc.
Resolved
This issue has been resolved.
Posted Jun 01, 2019 - 01:55 EDT
Investigating
Our team is aware of an issue with accessing our support and client area portals.
Posted Jun 01, 2019 - 01:36 EDT
This incident affected: Main Website.