Planned Maintenance
Incident Report for Hawk Host Inc.
Resolved
The maintenance has been completed.
Posted 6 months ago. Jan 05, 2018 - 02:17 EST
Monitoring
We're currently undergoing planned maintenance. During this time some facets of our support help desk and billing will be down.
Posted 6 months ago. Jan 05, 2018 - 02:03 EST