Client Area Inaccessible
Incident Report for Hawk Host Inc.
Resolved
This issue has been resolved and access to the client area is fully restored.
Posted May 11, 2020 - 09:50 EDT
Investigating
We are currently investigating an issue impacting access to our client area. This issue has no impact on customers websites or services.
Posted May 11, 2020 - 09:03 EDT
This incident affected: Main Website.